Activation and Reset Password Emails
Incident Report for Medallia Experience Orchestration
Resolved
This incident has now been resolved.
Posted Dec 08, 2021 - 09:21 EST
Investigating
Customers are encountering issues with not receiving activation or password reset emails. We are currently investigating the issue and will provide an update when we have more information.
Posted Dec 07, 2021 - 09:02 EST
This incident affected: MXO Europe (EU2).